miércoles, 10 de julio de 2013

Regresar a MATE 1.4 desde MATE 1.6 (o superior) en Linux Mint 13, y bloquearlo para que no vuelva a actualizarse

Si seguiste mi manual para instalar Mate 1.4 en Linux Mint 13 y si en los últimos meses has actualizado el sistema, estarás utilizando MATE 1.6 (con MintMenu si seguiste este otro manual).

¿Por qué volver a instalar MATE 1.4 y no quedarnos en la versión 1.6?
MATE 1.6, pese a poseer un número de versión ascendente progresivo, en realidad utiliza la biblioteca gráfica de GNOME 3, por lo que, aunque aparentemente no se vean cambios, ha habido varios internos significativos.

Si has utilizado ambas versiones (1.4 y 1.6), habrás observado que MATE 1.6 falla en aspectos como:
  • El rendimiento general se ha resentido. El entorno ha sufrido una significativa merma. Espero que sea únicamente porque es una versión nueva "bajo el bosque" (como dicen en inglés) y no porque utlice GTK+ 3, y que sea solucionado en posteriores actualizaciones.
  • El monitor del sistema es lento. mate-system-monitor no se cierra instantáneamente sino que tarda unos segundos -en los cuales accede a disco-. No sé lo que hace, pero eso es lo que ocurre.
  • Faltan opciones de configuración presentes en MATE 1.4. Por ejemplo: el botón "Hacer predeterminado" de mate-power-manager (el gestor de energía).
  • El menú principal de Linux Mint también es lento. MintMenu tarda en reaccionar cada vez que accedes a él tras iniciar sesión. Puede que sea un fallo propio y no del entorno de escritorio, pero es algo que en MATE 1.4 no ocurre.

Bien. Este manual lo voy a explicar en dos partes: parte 1, desinstalar MATE 1.6; parte 2, instalar o actualizar a MATE 1.4. Quienes aún no hayan actualizado a MATE 1.6 y quieran actualizar a MATE 1.4, que pasen directamente a la segunda parte.
Si no sabes qué versión de MATE estás utilizando, haz clic con el botón secundario del ratón en un área sin utilizar del panel principal y elige la opción Acerca de los paneles.

Vamos con el procedimiento.
Es un proceso un poco largo, pero sencillo si sigues los pasos.

PARTE 1: Desinstalar MATE 1.6.
Partimos de la base de que ya tienes MATE 1.6 funcionando en tu Linux Mint 13.
  1. Abrimos un editor de texto sencillo (Pluma) con privilegios de administrador para editar el archivo /etc/apt/preferences. Para ello, pulsamos la combinación de teclado Alt + F2, escribimos gksudo pluma /etc/apt/preferences y le damos a Ejecutar.
  2. Editamos el texto para que quede de la siguiente manera:
    Package: *
    Pin: release o=linuxmint
    Pin-Priority: 700
    
    Package: *
    Pin: origin packages.linuxmint.com
    Pin-Priority: 700
    
    Package: *
    Pin: release o=Ubuntu
    Pin-Priority: 500
    
  3. Guardamos los cambios y salimos del editor.
  4. Ahora vamos al gestor de paquetes Synaptic (en Menú - Gestor de paquetes) y deshabilitamos el repositorio oficial de MATE. En Configuración - Repositorios - Otro software - Deshabilitamos la casilla correspondiente a http://packages.mate-desktop.org/repo/ubuntu precise main. Ahora pulsamos en Cerrar, y en Recargar.
  5. Instalamos lxde y lxdm. En la pregunta de configuración de lxdm, lo seleccionamos en la lista y continuamos. Con esto hemos instalado el entorno de escritorio ligero LXDE y su gestor de acceso, que nos servirán mientras desinstalamos MATE 1.6 e instalamos MATE 1.4.
  6. Reiniciamos el ordenador e iniciamos sesión en LXDE.
  7. Desinstalamos MATE 1.6. Para ello, vamos de nuevo a Synaptic, en Filtro rápido escribimos mate, y marcamos para desinstalar por completo (opción Marcar para desinstalar completamente) todos los paquetes que contengan el texto mate en su nombre y 1.4 ó 1.6 como versión instalada, como muestra la captura de pantalla de abajo (en la imagen de ejemplo, no desinstalaríamos el paquete mate-media-gstreamer). Marcamos también para desinstalar completamente los paquetes mdm y mintmenu. Aceptamos las posibles preguntas y hacemos clic en Aplicar.
Gestor de paquetes Synaptic filtrando por mate
Ya tenemos MATE 1.6 desinstalado.

PARTE 2: Instalar o actualizar a MATE 1.4.
Partimos de la base de que ya tienes Linux Mint 13 funcionando.
  1. En el gestor de paquetes Synaptic (en Menú - Gestor de paquetes), vamos a Configuración - Repositorios y activamos la opción Backported packages (backport). Ahora pulsamos en Cerrar, y en Recargar.
  2. Si hemos seguido este manual desde la parte 1: instalamos los paquetes mint-meta-mate, mdm y mintmenu aceptando las posibles preguntas y haciendo clic en Aceptar. En la pregunta de configuración de mdm, lo seleccionamos en la lista y continuamos.
    Si por el contrario hemos comenzado desde la parte 2: cerramos Synaptic, hacemos clic en el gestor de actualizaciones (icono del escudo del panel de MATE) y actualizamos el sistema -gracias, amigo Jose, por avisarme de que para este caso no servía lo anterior-.
  3. Ahora bloqueamos el repositorio backports que hemos activado en el paso 1, y con ello las posibles -aunque poco probales- actualizaciones a MATE 1.6 por parte de Linux Mint. En el gestor de paquetes Synaptic, vamos a Configuración - Repositorios y desactivamos la opción Backported packages (backport). Ahora pulsamos en Cerrar, en Recargar, y cerramos Synaptic.
  4. Instalaremos ahora el soporte completo de idiomas. Vamos a Menú - Centro de Control - Language Support y aceptamos las peticiones.
Ya tenemos MATE 1.4 instalado. Reiniciamos el ordenador.
Ya podemos usar MATE 1.4 para siempre en Linux Mint 13 sin temor a que se actualice a versiones mayores (MATE ≥ 1.6) que no deseamos.

Quienes hemos comenzado desde la primera parte y queremos eliminar el entorno LXDE utilizado, vamos a Synaptic, en Filtro rápido escribimos lxde, y desinstalamos todos los paquetes que aparezcan instalados y que comiencen por lx. Desinstalamos también gpicview, leafpad y xarchiver.

No hay comentarios:

Publicar un comentario en la entrada

Tu comentario será publicado tan pronto como sea supervisado y aprobado.
No están permitidas las faltas de respeto ni la información sensible (como direcciones de correo o números de teléfono). Estos comentarios serán eliminados.

LinkWithin

Related Posts Plugin for WordPress, Blogger...